[webkit-reviews] review granted: [Bug 212110] Add _WKDownloadDelegate callback including totalBytesWritten : [Attachment 399781] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 19 17:15:07 PDT 2020


Geoffrey Garen <ggaren at apple.com> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 212110: Add _WKDownloadDelegate callback including totalBytesWritten
https://bugs.webkit.org/show_bug.cgi?id=212110

Attachment 399781: Patch

https://bugs.webkit.org/attachment.cgi?id=399781&action=review




--- Comment #7 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 399781
  --> https://bugs.webkit.org/attachment.cgi?id=399781
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=399781&action=review

r=me

> Tools/TestWebKitAPI/cocoa/TestDownloadDelegate.mm:49
> +- (void)_download:(_WKDownload *)download
didWriteData:(uint64_t)bytesWritten
totalBytesWritten:(uint64_t)totalBytesWritten
totalBytesExpectedToWrite:(uint64_t)totalBytesExpectedToWrite

I wonder if we can keep the didReceive naming pattern, to match the rest of the
API and other networking APIs.

didReceiveBytes:(uint64_t)bytes totalBytes:(uint64_t)totalBytes
totalBytesExpected:(uint64_t)totalBytesExpected


More information about the webkit-reviews mailing list