[webkit-reviews] review granted: [Bug 205645] Apply rotation at source level if WebRTC sink ask so : [Attachment 393143] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 11 09:35:11 PDT 2020


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 205645: Apply rotation at source level if WebRTC sink ask so
https://bugs.webkit.org/show_bug.cgi?id=205645

Attachment 393143: Patch

https://bugs.webkit.org/attachment.cgi?id=393143&action=review




--- Comment #10 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 393143
  --> https://bugs.webkit.org/attachment.cgi?id=393143
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=393143&action=review

> Source/WebCore/ChangeLog:9
> +	   By default, the method does nothing and RealtimeOyutgoingVideoSource
will continue to do the rotation itself.

s/RealtimeOyutgoingVideoSource/RealtimeOutgoingVideoSource/

> Source/WebCore/platform/graphics/cv/ImageRotationSessionVT.h:58
> +    ImageRotationSessionVT(const RotationProperties&, FloatSize, OSType
pixelFormat, IsCGImageCompatible);

Nit: "pixelFormat" doesn't seem necessary.

> Source/WebCore/platform/graphics/cv/ImageRotationSessionVT.h:72
> +    void initialize(const RotationProperties&, FloatSize, OSType
pixelFormat, IsCGImageCompatible);

Ditto.

> Source/WebCore/platform/graphics/cv/ImageRotationSessionVT.mm:101
>      CVPixelBufferPoolRef rawPool = nullptr;
>      if (auto err = CVPixelBufferPoolCreate(kCFAllocatorDefault, nullptr,
(__bridge CFDictionaryRef)pixelAttributes, &rawPool); err != noErr)

I now this isn't new, but it seems like a bad idea to use a NULL buffer pool if
this fails.

> Source/WebCore/platform/mediastream/RealtimeMediaSource.h:200
> +    virtual bool setShouldApplyRotation(bool /* shouldApplyRotation */) {
return false; }

Nit: the method name is quite descriptive so the commented out parameter name
doesn't seem necessary.

> Source/WebKit/UIProcess/Cocoa/UserMediaCaptureManagerProxy.cpp:195
> +    bool m_shouldApplyRotation { false };

It doesn't look like this is used.

> Source/WebKit/WebProcess/cocoa/UserMediaCaptureManager.cpp:226
> +    bool setShouldApplyRotation(bool /* shouldApplyRotation */) final;

Same comment as above.


More information about the webkit-reviews mailing list