[webkit-reviews] review denied: [Bug 213254] Rename TextEncoding::encode() to TextEncoding::encodeWithNormalization() : [Attachment 402015] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 17 18:14:10 PDT 2020

Alexey Proskuryakov <ap at webkit.org> has denied Tetsuharu Ohzeki
<tetsuharu.ohzeki at gmail.com>'s request for review:
Bug 213254: Rename TextEncoding::encode() to

Attachment 402015: Patch


--- Comment #2 from Alexey Proskuryakov <ap at webkit.org> ---
Comment on attachment 402015
  --> https://bugs.webkit.org/attachment.cgi?id=402015

View in context: https://bugs.webkit.org/attachment.cgi?id=402015&action=review

> Source/WebCore/ChangeLog:9
> +	   I'm planning to add a variant of `TextEncoding::encode()` which does
> +	   normalize to fix bug 213253.

I don't think that this is necessary. Once we perform normalization on ingress
(macOS file names, keyboard input etc.), TextEncoding::encode() won't need to
normalize ever. There isn't a need for a separate code path.

More information about the webkit-reviews mailing list