[webkit-reviews] review granted: [Bug 213020] [WebXR] unsigned long in IDL should be translated as unsigned in C++ code : [Attachment 401533] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 10 10:02:34 PDT 2020


Darin Adler <darin at apple.com> has granted Sergio Villar Senin
<svillar at igalia.com>'s request for review:
Bug 213020: [WebXR] unsigned long in IDL should be translated as unsigned in
C++ code
https://bugs.webkit.org/show_bug.cgi?id=213020

Attachment 401533: Patch

https://bugs.webkit.org/attachment.cgi?id=401533&action=review




--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 401533
  --> https://bugs.webkit.org/attachment.cgi?id=401533
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=401533&action=review

> Source/WebCore/Modules/webxr/WebXRSession.cpp:203
> +    unsigned newId = ++m_nextCallbackId;

This makes it clear that m_nextCallbackId is misnamed. Because we can see here
that in practice it contains the last already-used callback ID, not the next
callback ID to be used.

> Source/WebCore/Modules/webxr/WebXRSession.h:77
> +    void cancelAnimationFrame(unsigned handle);

A little inelegant that the header calls this "handle", but the .cpp file calls
it "callbackId".


More information about the webkit-reviews mailing list