[webkit-reviews] review granted: [Bug 212825] Make FAST_JIT_PERMISSIONS check in LinkBuffer::copyCompactAndLinkCode a runtime check : [Attachment 401188] Patch with suggested changes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 5 14:30:23 PDT 2020


Saam Barati <sbarati at apple.com> has granted Michael Saboff
<msaboff at apple.com>'s request for review:
Bug 212825: Make FAST_JIT_PERMISSIONS check in
LinkBuffer::copyCompactAndLinkCode a runtime check
https://bugs.webkit.org/show_bug.cgi?id=212825

Attachment 401188: Patch with suggested changes

https://bugs.webkit.org/attachment.cgi?id=401188&action=review




--- Comment #8 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 401188
  --> https://bugs.webkit.org/attachment.cgi?id=401188
Patch with suggested changes

View in context: https://bugs.webkit.org/attachment.cgi?id=401188&action=review

r=me

> Source/JavaScriptCore/ChangeLog:8
> +	   Made the FAST_JIT_PERMISSIONS code to be runtime conditional.

"code to be" => maybe something a bit more specific: "code when linking to be"

> Source/JavaScriptCore/ChangeLog:16
> +	   Broke out the "verify hash" conditionally compiled code with a file
local
> +	   ENABLE_VERIFY_JIT_HASH macro for readability.

this is nicer

> Source/JavaScriptCore/assembler/LinkBuffer.cpp:250
> +#if ENABLE(VERIFY_JIT_HASH)

can we assert that useFastJITPermissions() is true

alternatively, just return true from that function #if ENABLE(VERIFY_JIT_HASH)


More information about the webkit-reviews mailing list