[webkit-reviews] review granted: [Bug 212406] Use one audio unit for all MediaStreamTracks of a given process : [Attachment 400575] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 5 08:43:31 PDT 2020


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 212406: Use one audio unit for all MediaStreamTracks of a given process
https://bugs.webkit.org/show_bug.cgi?id=212406

Attachment 400575: Patch

https://bugs.webkit.org/attachment.cgi?id=400575&action=review




--- Comment #9 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 400575
  --> https://bugs.webkit.org/attachment.cgi?id=400575
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=400575&action=review

> Source/WebCore/platform/audio/mac/AudioSampleBufferList.cpp:-108
> +static void mixBuffers(WebAudioBufferList& destinationBuffer, const
AudioBufferList& sourceBuffer, AudioStreamDescription::PCMFormat format, size_t
frameCount)
>  {
> -    ASSERT(source.streamDescription() == streamDescription());

ASSERT(frameCount <= sourceBuffer.sampleCount()) ?

> Source/WebCore/platform/audio/mac/AudioSampleDataSource.mm:294
> +	   if (m_volume < .95)

Not new to this patch but the magic number should be a named constant,
especially since it is used in more than one place now.


More information about the webkit-reviews mailing list