[webkit-reviews] review granted: [Bug 214882] Improve range idioms and other changes to prepare the way for more reduction in live range use : [Attachment 405427] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 28 19:17:04 PDT 2020


Sam Weinig <sam at webkit.org> has granted Darin Adler <darin at apple.com>'s request
for review:
Bug 214882: Improve range idioms and other changes to prepare the way for more
reduction in live range use
https://bugs.webkit.org/show_bug.cgi?id=214882

Attachment 405427: Patch

https://bugs.webkit.org/attachment.cgi?id=405427&action=review




--- Comment #3 from Sam Weinig <sam at webkit.org> ---
Comment on attachment 405427
  --> https://bugs.webkit.org/attachment.cgi?id=405427
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=405427&action=review

> Source/WebCore/accessibility/AccessibilityObject.cpp:1181
>  VisiblePositionRange AccessibilityObject::lineRangeForPosition(const
VisiblePosition& visiblePosition) const
>  {
> -    VisiblePosition startPosition = startOfLine(visiblePosition);
> -    VisiblePosition endPosition = endOfLine(visiblePosition);
> -    return VisiblePositionRange(startPosition, endPosition);
> +    return { startOfLine(visiblePosition), endOfLine(visiblePosition) };

Some of these functions don't seem like they belong as member functions on
AccessibilityObject, given how general they are, and that they don't seem to be
using any state or functions of AccessibilityObject. In another change (not
this one), it might be a good idea to move some of these to VisibileUnit.h or
similar.


More information about the webkit-reviews mailing list