[webkit-reviews] review granted: [Bug 214340] There should be only one RunLoop Timer class : [Attachment 404633] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jul 19 11:20:04 PDT 2020


Darin Adler <darin at apple.com> has granted Geoffrey Garen <ggaren at apple.com>'s
request for review:
Bug 214340: There should be only one RunLoop Timer class
https://bugs.webkit.org/show_bug.cgi?id=214340

Attachment 404633: Patch

https://bugs.webkit.org/attachment.cgi?id=404633&action=review




--- Comment #9 from Darin Adler <darin at apple.com> ---
Comment on attachment 404633
  --> https://bugs.webkit.org/attachment.cgi?id=404633
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=404633&action=review

Wish there was slightly more abstraction so we didn’t have to say
COCOA_EVENT_LOOP all the time.

> Source/WTF/wtf/RunLoop.h:53
> +typedef HashSet<RefPtr<SchedulePair>, SchedulePairHash> SchedulePairHashSet;

In new code we should use "using" instead of typedef.

> Source/WTF/wtf/cf/RunLoopCF.cpp:94
> +	   Function<void()>
function(static_cast<Function<void()>::Impl*>(context));

Kind of wish this function constructor was named since it takes ownership. A
sort of asymmetry with leakImpl.

> Source/WTF/wtf/cf/RunLoopCF.cpp:122
> +	   TimerBase* timer = static_cast<TimerBase*>(context);

auto?


More information about the webkit-reviews mailing list