[webkit-reviews] review denied: [Bug 206443] [bmalloc] Define alias for std::unique_lock and std::lock_guard for better readability : [Attachment 388089] PATCH

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 17 14:50:07 PST 2020


Yusuke Suzuki <ysuzuki at apple.com> has denied Basuke Suzuki
<Basuke.Suzuki at sony.com>'s request for review:
Bug 206443: [bmalloc] Define alias for std::unique_lock and std::lock_guard for
better readability
https://bugs.webkit.org/show_bug.cgi?id=206443

Attachment 388089: PATCH

https://bugs.webkit.org/attachment.cgi?id=388089&action=review




--- Comment #2 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 388089
  --> https://bugs.webkit.org/attachment.cgi?id=388089
PATCH

View in context: https://bugs.webkit.org/attachment.cgi?id=388089&action=review

Loks good overall.

> Source/bmalloc/bmalloc/Mutex.h:41
> +using SimpleLock = std::lock_guard<Mutex>;

Rename it to UniqueLockHolder and LockHolder. The name “Lock” means the lock
itself instead of RAII styled locking class.
And consider using scoped_lock instead of lock_guard. Maybe we can use it now?
(C++17)


More information about the webkit-reviews mailing list