[webkit-reviews] review granted: [Bug 197684] [Win] Implement NetworkCache::Data by using FileSystem::MappedFileData : [Attachment 391685] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 25 17:25:59 PST 2020


Yusuke Suzuki <ysuzuki at apple.com> has granted Christopher Reid
<chris.reid at sony.com>'s request for review:
Bug 197684: [Win] Implement NetworkCache::Data by using
FileSystem::MappedFileData
https://bugs.webkit.org/show_bug.cgi?id=197684

Attachment 391685: patch

https://bugs.webkit.org/attachment.cgi?id=391685&action=review




--- Comment #38 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 391685
  --> https://bugs.webkit.org/attachment.cgi?id=391685
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391685&action=review

r=me

> Source/WTF/ChangeLog:16
> +	   Added onlyCreateFile flag to openFile which causes openFile to fail
if the file already exists.

We should name this flag as `failIfFileExists`

> Source/WebKit/NetworkProcess/cache/NetworkCacheData.cpp:43
> +    auto handle = FileSystem::openFile(path,
FileSystem::FileOpenMode::ReadWrite, FileSystem::FileAccessPermission::User,
true);

Let's not pass boolean directly, it is hard to read what this bool means.

constexpr bool failIfFileExists = true;
auto handle = FileSystem::openFile(path, ..., failIfFileExists);

is better.


More information about the webkit-reviews mailing list