[webkit-reviews] review granted: [Bug 207502] Rename VideoFullscreenLayerManager to VideoLayerManager : [Attachment 390302] A clearer patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 11 05:29:57 PST 2020


youenn fablet <youennf at gmail.com> has granted Peng Liu <peng.liu6 at apple.com>'s
request for review:
Bug 207502: Rename VideoFullscreenLayerManager to VideoLayerManager
https://bugs.webkit.org/show_bug.cgi?id=207502

Attachment 390302: A clearer patch

https://bugs.webkit.org/attachment.cgi?id=390302&action=review




--- Comment #4 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 390302
  --> https://bugs.webkit.org/attachment.cgi?id=390302
A clearer patch

View in context: https://bugs.webkit.org/attachment.cgi?id=390302&action=review

>> Source/WebCore/WebCore.xcodeproj/project.pbxproj:-846
>> -		2DDE1D081F574D0E00D1A365 /* JSVRStageParameters.h in Headers */
= {isa = PBXBuildFile; fileRef = 2DDE1CF61F574BFF00D1A365 /*
JSVRStageParameters.h */; };
> 
> Those are cleanup for https://trac.webkit.org/changeset/255241/webkit

Could we try to not include these changes, or as separate unreviewed changes
maybe. Ditto for below.

>
Source/WebCore/platform/graphics/avfoundation/objc/MediaPlayerPrivateMediaSourc
eAVFObjC.h:328
> +    std::unique_ptr<VideoLayerManagerObjC> m_videoLayerManager;

We could use UniqueRef.

>
Source/WebCore/platform/graphics/avfoundation/objc/MediaPlayerPrivateMediaStrea
mAVFObjC.h:245
> +    std::unique_ptr<VideoLayerManagerObjC> m_videoLayerManager;

Ditto here.


More information about the webkit-reviews mailing list