[webkit-reviews] review granted: [Bug 168716] Implement WebVTT VTTCue region attribute : [Attachment 416044] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 11 15:44:36 PST 2020


Eric Carlson <eric.carlson at apple.com> has granted frankolivier at apple.com's
request for review:
Bug 168716: Implement WebVTT VTTCue region attribute
https://bugs.webkit.org/show_bug.cgi?id=168716

Attachment 416044: Patch

https://bugs.webkit.org/attachment.cgi?id=416044&action=review




--- Comment #6 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 416044
  --> https://bugs.webkit.org/attachment.cgi?id=416044
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=416044&action=review

> Source/WebCore/html/track/TextTrackCueGeneric.cpp:97
> +	   

Nit: don't need this new whitespace

> Source/WebCore/html/track/VTTCue.cpp:199
> +    

Ditto.

> Source/WebCore/html/track/VTTCue.cpp:584
> +	   // return Exception { SyntaxError };

Did you mean to leave this commented out?

> Source/WebCore/html/track/VTTCue.cpp:1063
> +	   if (m_region) {
> +	       if (m_displayTree)
> +		   m_region->willRemoveTextTrackCueBox(m_displayTree.get());
>	   }

Nit: this could be simplified to `if (m_region && m_displayTree) ...`

> Source/WebCore/html/track/VTTCue.h:210
> +//	 bool linePositionIsAuto() const;

Should this be deleted?

> Source/WebCore/rendering/RenderVTTCue.cpp:62
> +    

Nit: whitespace

> Source/WebCore/rendering/RenderVTTCue.cpp:391
> +
> +

Nit: extra blank line


More information about the webkit-reviews mailing list