[webkit-reviews] review denied: [Bug 219760] REGRESSION (r270458): Canvas painting is broken when enabling GPU process for DOM : [Attachment 415943] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 10 16:52:49 PST 2020


Said Abou-Hallawa <sabouhallawa at apple.com> has denied Wenson Hsieh
<wenson_hsieh at apple.com>'s request for review:
Bug 219760: REGRESSION (r270458): Canvas painting is broken when enabling GPU
process for DOM
https://bugs.webkit.org/show_bug.cgi?id=219760

Attachment 415943: Patch

https://bugs.webkit.org/attachment.cgi?id=415943&action=review




--- Comment #7 from Said Abou-Hallawa <sabouhallawa at apple.com> ---
Comment on attachment 415943
  --> https://bugs.webkit.org/attachment.cgi?id=415943
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=415943&action=review

> Source/WebCore/platform/graphics/ImageBufferBackend.cpp:61
> +IntSize ImageBufferBackend::backendSize() const
> +{
> +    return calculateBackendSize(logicalSize(), resolutionScale());
> +}

I do not think this is the right approach.

If you want to add this function, what is the point of having these functions?

ImageBufferCairoSurfaceBackend::backendSize()
ImageBufferCGBitmapBackend::backendSize()
ImageBufferIOSurfaceBackend::backendSize()

They can all be deleted if you make this change. When I did r270458, I thought
because ImageBufferShareableIOSurfaceBackend does not have an IOSurface, it
makes sense to return a backendSize = { 0, 0 }. In fact I thought we should
ASSERT_NOT_REACHED if ImageBufferBackend::backendSize() is ever called. The
goal of this change was to have a single place to get the backendSize which is
the backend itself (IOSurface or CGContext) not from a calculated value.

Are you sure you want the backendSize not the logicalSize?


More information about the webkit-reviews mailing list