[webkit-reviews] review granted: [Bug 219698] [iOS][FCR] Add new look for input type=range : [Attachment 415779] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 9 16:33:58 PST 2020

Wenson Hsieh <wenson_hsieh at apple.com> has granted Aditya Keerthi
<akeerthi at apple.com>'s request for review:
Bug 219698: [iOS][FCR] Add new look for input type=range

Attachment 415779: Patch


--- Comment #4 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 415779
  --> https://bugs.webkit.org/attachment.cgi?id=415779

View in context: https://bugs.webkit.org/attachment.cgi?id=415779&action=review

> Source/WebCore/rendering/RenderThemeIOS.mm:2225
> +bool RenderThemeIOS::paintSliderTrackFCR(const RenderObject& box, const
PaintInfo& paintInfo, const IntRect& rect)

Nit - we typically refrain from using acronyms and acronyms in function names
like this (https://webkit.org/code-style-guidelines/#names-full-words). I think
we should either just roll this into the call site, or rename this to
`paintSliderTrackWithFormControlRedesign()`. If we do decide to keep this
helper, we should also move its declaration in to the `private` section in the
header (RenderThemeIOS.h).

More information about the webkit-reviews mailing list