[webkit-reviews] review granted: [Bug 219524] [iOS] Provide a context menu action to perform accessibility image extraction : [Attachment 415375] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 4 08:05:25 PST 2020


Wenson Hsieh <wenson_hsieh at apple.com> has granted Devin Rousso
<drousso at apple.com>'s request for review:
Bug 219524: [iOS] Provide a context menu action to perform accessibility image
extraction
https://bugs.webkit.org/show_bug.cgi?id=219524

Attachment 415375: Patch

https://bugs.webkit.org/attachment.cgi?id=415375&action=review




--- Comment #2 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 415375
  --> https://bugs.webkit.org/attachment.cgi?id=415375
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=415375&action=review

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.h:76
> +- (void)actionSheetAssistant:(WKActionSheetAssistant *)assistant
imageExtraction:(UIImage *)image;

Nit - this is a bit of a funny name for a delegate method. Usually, it's either
a noun (if the delegate returns something), like `- (Foo
*)instance:fooForPurpose:`, or it's a verb, like `- (void)instance:doFoo:`.
Maybe this should be something along the lines of
`-actionSheetAssistant:extractImage:` or
`-actionSheetAssistant:handleImageExtraction:`.


More information about the webkit-reviews mailing list