[webkit-reviews] review granted: [Bug 170553] [GTK] Misplaced right click menu on web page due to deprecated gtk_menu_popup() : [Attachment 397748] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 28 05:46:29 PDT 2020


Carlos Garcia Campos <cgarcia at igalia.com> has granted Adrian Perez
<aperez at igalia.com>'s request for review:
Bug 170553: [GTK] Misplaced right click menu on web page due to deprecated
gtk_menu_popup()
https://bugs.webkit.org/show_bug.cgi?id=170553

Attachment 397748: Patch

https://bugs.webkit.org/attachment.cgi?id=397748&action=review




--- Comment #33 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 397748
  --> https://bugs.webkit.org/attachment.cgi?id=397748
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=397748&action=review

> Source/WebCore/ChangeLog:8
> +	   * platform/gtk/GtkVersioning.h: Add replacements for GtkPopover
functions which are no longet available in GTK4.

We should add GtkVersioning.h as an exception to be skipped by the style
checker. It can be done in a separate patch.

> Source/WebKit/UIProcess/API/gtk/WebKitWebViewBase.cpp:1662
> +static void activeContextMenuUnmapped(GtkWidget* widget, WebKitWebViewBase*
webViewBase)

I would rename this as Closed since this is no longer unmap callback.

> Tools/TestWebKitAPI/Tests/WebKitGtk/TestContextMenu.cpp:31
> +    WTF::Function<bool(GtkWidget*)> predicate;

You don't need WTF::

> Tools/TestWebKitAPI/Tests/WebKitGtk/TestContextMenu.cpp:32
> +    WTF::Vector<GtkWidget*> result { };

Ditto, nor the initialization.


More information about the webkit-reviews mailing list