[webkit-reviews] review granted: [Bug 211026] Commit the scrolling tree from the main thread : [Attachment 397573] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 25 13:05:41 PDT 2020


Darin Adler <darin at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 211026: Commit the scrolling tree from the main thread
https://bugs.webkit.org/show_bug.cgi?id=211026

Attachment 397573: Patch

https://bugs.webkit.org/attachment.cgi?id=397573&action=review




--- Comment #4 from Darin Adler <darin at apple.com> ---
Comment on attachment 397573
  --> https://bugs.webkit.org/attachment.cgi?id=397573
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=397573&action=review

> Source/WebCore/page/scrolling/ScrollingCoordinator.h:71
> +using PlatformDisplayID = uint32_t;

I think this name would work just as well without the word "platform" in it.

> Source/WebCore/page/scrolling/ScrollingTree.h:57
> +#if ENABLE(SCROLLING_THREAD)
> +using PlatformDisplayID = uint32_t;
> +#endif

Same comment as above that I don’t think the word "platform" is helpful in this
name.

Is there some way to avoid defining this type separately in multiple headers?

Please add a blank line before this since it doesn’t fit great into the
paragraph of forward-declared classes.

> Source/WebCore/page/scrolling/mac/ScrollingCoordinatorMac.mm:108
> +    auto stateTree =
scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation);
> +    scrollingTree()->commitTreeState(WTFMove(stateTree));

Would this read better as a single line?

> Source/WebCore/page/scrolling/nicosia/ScrollingCoordinatorNicosia.cpp:98
> +    auto stateTree =
scrollingStateTree()->commit(LayerRepresentation::PlatformLayerRepresentation);
> +    scrollingTree()->commitTreeState(WTFMove(stateTree));

Would this read better as a single line?


More information about the webkit-reviews mailing list