[webkit-reviews] review granted: [Bug 210988] [Web Animations] Ensure calling Web Animations APIs override future CSS Animations style properties : [Attachment 397495] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 24 13:30:49 PDT 2020


Dean Jackson <dino at apple.com> has granted Antoine Quint <graouts at apple.com>'s
request for review:
Bug 210988: [Web Animations] Ensure calling Web Animations APIs override future
CSS Animations style properties
https://bugs.webkit.org/show_bug.cgi?id=210988

Attachment 397495: Patch

https://bugs.webkit.org/attachment.cgi?id=397495&action=review




--- Comment #2 from Dean Jackson <dino at apple.com> ---
Comment on attachment 397495
  --> https://bugs.webkit.org/attachment.cgi?id=397495
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=397495&action=review

> Source/WebCore/animation/WebAnimation.cpp:151
> +void WebAnimation::setBindingsEffect(RefPtr<AnimationEffect>&& newEffect)
> +{
> +    setEffect(WTFMove(newEffect));
> +}

Why does this need a different name for bindings? And the other two below.


More information about the webkit-reviews mailing list