[webkit-reviews] review granted: [Bug 210138] [Cocoa] Simplify NSArray, NSDictionary, and NSNumber idioms throughout WebKit : [Attachment 395905] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 9 17:01:33 PDT 2020


Alex Christensen <achristensen at apple.com> has granted Darin Adler
<darin at apple.com>'s request for review:
Bug 210138: [Cocoa] Simplify NSArray, NSDictionary, and NSNumber idioms
throughout WebKit
https://bugs.webkit.org/show_bug.cgi?id=210138

Attachment 395905: Patch

https://bugs.webkit.org/attachment.cgi?id=395905&action=review




--- Comment #19 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 395905
  --> https://bugs.webkit.org/attachment.cgi?id=395905
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=395905&action=review

> Source/WTF/wtf/cocoa/VectorCocoa.h:69
> +	   constexpr const VectorElementType* typedNull = nullptr;
> +	   if (auto vectorElement = makeVectorElement(typedNull, element))

I think all this is great.  It's a wonderful improvement to our code.  I think
it would be even better if it looked like this:
if (auto vectorElement = makeVectorElement<VectorElementType>(element))
I think we could also do that later if we decide that's indeed better.	This
isn't bad either.


More information about the webkit-reviews mailing list