[webkit-reviews] review granted: [Bug 210107] Bump priority of LibWebRTCAudioModule thread : [Attachment 395951] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 9 08:46:54 PDT 2020


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 210107: Bump priority of LibWebRTCAudioModule thread
https://bugs.webkit.org/show_bug.cgi?id=210107

Attachment 395951: Patch

https://bugs.webkit.org/attachment.cgi?id=395951&action=review




--- Comment #4 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 395951
  --> https://bugs.webkit.org/attachment.cgi?id=395951
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=395951&action=review

> Source/WebCore/platform/mediastream/libwebrtc/LibWebRTCAudioModule.cpp:73
>  void LibWebRTCAudioModule::StartPlayoutOnAudioThread()

This name seems wrong now that it is essentially a one-shot. Maybe something
like `PullDataOnAudioThread`, or fold maybe the logic into PollFromSource
instead?

> Source/WebCore/platform/mediastream/libwebrtc/LibWebRTCAudioModule.cpp:102
> +	   char data[(LibWebRTCAudioFormat::sampleByteSize * channels *
LibWebRTCAudioFormat::chunkSampleCount)];

Now that the chunk size is constant (for a given channel count), maybe we
should use a member variable that is (re)allocated when the number of channels
changes?


More information about the webkit-reviews mailing list