[webkit-reviews] review granted: [Bug 209886] ActiveDOMObject::hasPendingActivity() should stop preventing wrapper collection after ActiveDOMObject::stop() has been called : [Attachment 395283] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 2 14:19:49 PDT 2020


Ryosuke Niwa <rniwa at webkit.org> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 209886: ActiveDOMObject::hasPendingActivity() should stop preventing
wrapper collection after ActiveDOMObject::stop() has been called
https://bugs.webkit.org/show_bug.cgi?id=209886

Attachment 395283: Patch

https://bugs.webkit.org/attachment.cgi?id=395283&action=review




--- Comment #8 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 395283
  --> https://bugs.webkit.org/attachment.cgi?id=395283
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=395283&action=review

> Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:4777
> -	       push(@implContent, "    if
(js${interfaceName}->wrapped().hasPendingActivity()) {\n");
> +	       push(@implContent, "    if
(!js${interfaceName}->wrapped().isContextStopped() &&
js${interfaceName}->wrapped().hasPendingActivity()) {\n");

Can we add a helper function like hasPendingActivityAndNotStopped so that we
don't do de-referencing twice here?


More information about the webkit-reviews mailing list