[webkit-reviews] review granted: [Bug 201850] Wasm StreamingParser should validate that number of functions matches number of declarations : [Attachment 378916] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 16 17:46:53 PDT 2019


Yusuke Suzuki <ysuzuki at apple.com> has granted Tadeu Zagallo
<tzagallo at apple.com>'s request for review:
Bug 201850: Wasm StreamingParser should validate that number of functions
matches number of declarations
https://bugs.webkit.org/show_bug.cgi?id=201850

Attachment 378916: Patch

https://bugs.webkit.org/attachment.cgi?id=378916&action=review




--- Comment #2 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 378916
  --> https://bugs.webkit.org/attachment.cgi?id=378916
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=378916&action=review

r=me

> Source/JavaScriptCore/wasm/WasmStreamingParser.cpp:389
> +	   if (m_functionCount != m_info->functions.size()) {
> +	       m_state = fail("Number of functions parsed (", m_functionCount,
") does not match the number of declared functions (",
m_info->functions.size(), ")");
> +	       break;
> +	   }

I suggest using m_functionIndex mainly for readability.


More information about the webkit-reviews mailing list