[webkit-reviews] review granted: [Bug 203625] [GTK] Web Inspector: inspector/timeline/timeline-event-*.html are failing : [Attachment 382400] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 30 21:07:26 PDT 2019


Devin Rousso <drousso at apple.com> has granted Yury Semikhatsky
<yurys at chromium.org>'s request for review:
Bug 203625: [GTK] Web Inspector: inspector/timeline/timeline-event-*.html are
failing
https://bugs.webkit.org/show_bug.cgi?id=203625

Attachment 382400: Patch

https://bugs.webkit.org/attachment.cgi?id=382400&action=review




--- Comment #4 from Devin Rousso <drousso at apple.com> ---
Comment on attachment 382400
  --> https://bugs.webkit.org/attachment.cgi?id=382400
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=382400&action=review

rs=me

> LayoutTests/inspector/timeline/resources/timeline-event-utilities.js:9
> +	   let pageRecordingData =
InspectorTest.awaitEvent("SavePageData").then((event) => {

NIT: we should call this `savePageDataPromise` since it doesn't actually hold
the data anymore.

> LayoutTests/inspector/timeline/resources/timeline-event-utilities.js:35
> -		   .catch(promise.reject);
> +		   .catch((error) => {
> +		       promise.reject(error);
> +		   });

Why was this changed?

> LayoutTests/inspector/timeline/resources/timeline-event-utilities.js:43
> +		   pageRecordingData.then((r) => {
> +		       promise.resolve(r);

Once we change the name to `savePageDataPromise`, I'd expect `r` to be renamed
to `data`.


More information about the webkit-reviews mailing list