[webkit-reviews] review granted: [Bug 202187] [JSC] Date functions should have intrinsic : [Attachment 382275] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 30 16:34:39 PDT 2019


Keith Miller <keith_miller at apple.com> has granted Yusuke Suzuki
<ysuzuki at apple.com>'s request for review:
Bug 202187: [JSC] Date functions should have intrinsic
https://bugs.webkit.org/show_bug.cgi?id=202187

Attachment 382275: Patch

https://bugs.webkit.org/attachment.cgi?id=382275&action=review




--- Comment #11 from Keith Miller <keith_miller at apple.com> ---
Comment on attachment 382275
  --> https://bugs.webkit.org/attachment.cgi?id=382275
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=382275&action=review

r=me with comments.

> Source/JavaScriptCore/dfg/DFGAbstractInterpreterInlines.h:4072
> +	   setNonCellTypeForNode(node, SpecBytecodeNumber);

Can say this is SpecInt32Only | SpecDoublePureNaN instead of
SpecBytecodeNumber?

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:3203
> +	       setResult(addToGraph(DateGetMachineDouble, OpInfo(intrinsic),
OpInfo(), base));

Can we rename this to date get time?

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:3229
> +	       setResult(addToGraph(DateGetJSNumber, OpInfo(intrinsic),
OpInfo(prediction), base));

Hmm, can we rename this to DateGetInt32OrNaN? This implies that it can return
any JSNumber but it can only vend an int32 or NaN.

> Source/JavaScriptCore/dfg/DFGSpeculativeJIT.cpp:14029
> +

Please remove.


More information about the webkit-reviews mailing list