[webkit-reviews] review granted: [Bug 203426] Add SSL support for peformance dashboard database connection. : [Attachment 381948] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 25 13:38:01 PDT 2019


Ryosuke Niwa <rniwa at webkit.org> has granted dewei_zhu at apple.com's request for
review:
Bug 203426: Add SSL support for peformance dashboard database connection.
https://bugs.webkit.org/show_bug.cgi?id=203426

Attachment 381948: Patch

https://bugs.webkit.org/attachment.cgi?id=381948&action=review




--- Comment #2 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 381948
  --> https://bugs.webkit.org/attachment.cgi?id=381948
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=381948&action=review

> Websites/perf.webkit.org/public/include/db.php:121
> +	   $connectionString = 'host=' . $databaseConfig['host'] . ' port=' .
$databaseConfig['port']
> +	       . ' dbname=' . $databaseConfig['name'] . ' user=' .
$databaseConfig['username'] . ' password=' . $databaseConfig['password'];

This string concatenation is hard to read. Can we define local variables and
do:
"host=$host port=$port dbname=$dbname user=$user password=$password"?

> Websites/perf.webkit.org/public/include/db.php:136
> +		   $sslConfigString .= ' ssl' . $key . '=' . $path;

Why not just $sslConfigString .= "ssl $key = $path"?


More information about the webkit-reviews mailing list