[webkit-reviews] review granted: [Bug 204262] Resource Load Statistics: Count third-party script loads under top frame : [Attachment 383675] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 18 16:17:01 PST 2019

Alex Christensen <achristensen at apple.com> has granted John Wilander
<wilander at apple.com>'s request for review:
Bug 204262: Resource Load Statistics: Count third-party script loads under top

Attachment 383675: Patch


--- Comment #10 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 383675
  --> https://bugs.webkit.org/attachment.cgi?id=383675

View in context: https://bugs.webkit.org/attachment.cgi?id=383675&action=review

r=me other than that.

>>> Source/WebCore/loader/ResourceLoadObserver.h:41
>>> +	 enum class IsScriptLikeSubresource : bool { Yes, No };
>> I don't think this is a good name.  I think instead isScriptLikeDestination
should be renamed to something more descriptive of what is going on.
>> Also, its implementation says it has something to do with service workers,
but I don't see any tests involving service workers.
> I assume you mean IsScriptLikeSubresource should be renamed. Any suggestions?
At least the direction you would like it to go.

isScriptLikeDestination -> fetchDestinationIsScriptLike to indicate it is for
fetch.	Maybe a link to
https://fetch.spec.whatwg.org/#request-destination-script-like somewhere.
IsScriptLikeSubresource isn't so bad once I understood that.

More information about the webkit-reviews mailing list