[webkit-reviews] review granted: [Bug 204149] [JSC] BlockDirectory's bits should be compact : [Attachment 383532] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 13 18:36:59 PST 2019


Robin Morisset <rmorisset at apple.com> has granted Yusuke Suzuki
<ysuzuki at apple.com>'s request for review:
Bug 204149: [JSC] BlockDirectory's bits should be compact
https://bugs.webkit.org/show_bug.cgi?id=204149

Attachment 383532: Patch

https://bugs.webkit.org/attachment.cgi?id=383532&action=review




--- Comment #20 from Robin Morisset <rmorisset at apple.com> ---
Comment on attachment 383532
  --> https://bugs.webkit.org/attachment.cgi?id=383532
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=383532&action=review

r=me

> Source/JavaScriptCore/heap/BlockDirectoryBits.h:156
> +	       for (unsigned i =
BlockDirectoryBitVectorView<kind>::arrayLength(); i--;)

Is there a reason for the previous function using Base::arrayLength() while
this one is using BlockDirectoryBitVectorView<kind>::arrayLength() ?

> Source/JavaScriptCore/heap/BlockDirectoryBits.h:191
> +    BlockDirectoryBitVectorRef<Kind::capitalBitName> lowerBitName() \

I don't think this function is useful as long as you have the one above.
Either delete it, or make it return a const
BlockDirectoryBitVectorRef<Kind::capitalBitName>


More information about the webkit-reviews mailing list