[webkit-reviews] review granted: [Bug 203714] Add a helper function to schedule a task to dispatch an event to ActiveDOMObject : [Attachment 382660] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Nov 2 11:58:24 PDT 2019


Chris Dumez <cdumez at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 203714: Add a helper function to schedule a task to dispatch an event to
ActiveDOMObject
https://bugs.webkit.org/show_bug.cgi?id=203714

Attachment 382660: Patch

https://bugs.webkit.org/attachment.cgi?id=382660&action=review




--- Comment #17 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 382660
  --> https://bugs.webkit.org/attachment.cgi?id=382660
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=382660&action=review

Patch will need rebaselining.

>> Source/WebCore/dom/ActiveDOMObject.h:134
>> +	    queueTaskKeepingThisObjectAlive(target, source, [&target,
movedEvent = WTFMove(event)] () mutable {
> 
> How is capturing target by reference safe here?
> movedEvent can simply be called event.

Oh, queueTaskKeepingThisObjectAlive() protected target so it is safe to capture
it by reference indeed.


More information about the webkit-reviews mailing list