[webkit-reviews] review granted: [Bug 197905] Make LOG_WITH_STREAM more efficient : [Attachment 369929] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 15 07:48:13 PDT 2019


Alex Christensen <achristensen at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 197905: Make LOG_WITH_STREAM more efficient
https://bugs.webkit.org/show_bug.cgi?id=197905

Attachment 369929: Patch

https://bugs.webkit.org/attachment.cgi?id=369929&action=review




--- Comment #2 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 369929
  --> https://bugs.webkit.org/attachment.cgi?id=369929
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369929&action=review

> Source/WTF/wtf/text/TextStream.h:109
> +    struct repeat {
> +	   repeat(char inCharacter, unsigned inWidth)
> +	       : width(inWidth)
> +	       , character(inCharacter)
> +	   { }

I think this should be named Repeat.
I think initializer lists could be used instead of this constructor.

> Source/WebCore/PAL/pal/LogMacros.h:35
> +	   if (JOIN_LOG_CHANNEL_WITH_PREFIX(LOG_CHANNEL_PREFIX, channel).state
== WTFLogChannelState::On) { \

This seems like an obvious check we should've done before.


More information about the webkit-reviews mailing list