[webkit-reviews] review granted: [Bug 197510] -[WKWebsiteDataStore removeDataOfTypes:forDataRecords:completionHandler:] doesn't delete _WKWebsiteDataTypeCredentials : [Attachment 369127] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 6 12:55:31 PDT 2019


Alex Christensen <achristensen at apple.com> has granted Per Arne Vollan
<pvollan at apple.com>'s request for review:
Bug 197510: -[WKWebsiteDataStore
removeDataOfTypes:forDataRecords:completionHandler:] doesn't delete
_WKWebsiteDataTypeCredentials
https://bugs.webkit.org/show_bug.cgi?id=197510

Attachment 369127: Patch

https://bugs.webkit.org/attachment.cgi?id=369127&action=review




--- Comment #11 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 369127
  --> https://bugs.webkit.org/attachment.cgi?id=369127
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369127&action=review

> Source/WebCore/platform/network/CredentialStorage.cpp:96
> +	       || (!origin.port && protectionSpace.port() == 80))

I think this should be indented 4 more spaces.

> Source/WebCore/platform/network/CredentialStorage.cpp:98
> +	       || (protectionSpace.serverType() == ProtectionSpaceServerHTTPS
&& origin.protocol == "https"_s)))

ditto

> Source/WebCore/platform/network/CredentialStorage.cpp:104
> +	   auto& partitionName = key.first;
> +	   auto& protectionSpace = key.second;
> +	   remove(partitionName, protectionSpace);

I don't think these named variables help the readability of this code
significantly.

> Source/WebCore/platform/network/CredentialStorage.cpp:130
> +	       ASSERT_NOT_REACHED();

'continue' after this?


More information about the webkit-reviews mailing list