[webkit-reviews] review granted: [Bug 195132] Web Inspector: Provide UIString descriptions to improve localizations : [Attachment 368218] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri May 3 23:13:17 PDT 2019
Devin Rousso <drousso at apple.com> has granted Nikita Vasilyev
<nvasilyev at apple.com>'s request for review:
Bug 195132: Web Inspector: Provide UIString descriptions to improve
localizations
https://bugs.webkit.org/show_bug.cgi?id=195132
Attachment 368218: Patch
https://bugs.webkit.org/attachment.cgi?id=368218&action=review
--- Comment #28 from Devin Rousso <drousso at apple.com> ---
Comment on attachment 368218
--> https://bugs.webkit.org/attachment.cgi?id=368218
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=368218&action=review
r=me, nice work!
> Source/WebInspectorUI/Localizations/en.lproj/localizedStrings.js:1121
> +/* Amount of data sent over the network */
Maybe add "for a single resource" at the end?
> Tools/Scripts/extract-localizable-js-strings:78
> + # Allow: WI.UIString(string, comment)
> + # WI.UIString(string, key, comment)
So I just realized something. There's no real need for a version that has
`WI.UIString(string, key, comment)` because the `comment` can BE the `key`.
Both `comment` and `key` are basic strings, so why don't we just always have
the `comment` be the `key` and completely drop support for `key`.
```
WI.UIString("layout", "Layout", "Layout @ Timeline record", "Layout phase
timeline records")
```
is really no different than
```
WI.UIString("layout", "Layout phase timeline records")
```
It's fine if you don't want to make that change in this patch, but I think it's
a bit of a 🤦♂️ on my part.
More information about the webkit-reviews
mailing list