[webkit-reviews] review granted: [Bug 196160] [JSC] Butterfly allocation from LargeAllocation should try "realloc" behavior if collector thread is not active : [Attachment 366331] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 31 16:44:36 PDT 2019


Saam Barati <sbarati at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 196160: [JSC] Butterfly allocation from LargeAllocation should try
"realloc" behavior if collector thread is not active
https://bugs.webkit.org/show_bug.cgi?id=196160

Attachment 366331: Patch

https://bugs.webkit.org/attachment.cgi?id=366331&action=review




--- Comment #46 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 366331
  --> https://bugs.webkit.org/attachment.cgi?id=366331
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=366331&action=review

r=me

> Source/JavaScriptCore/heap/AlignedMemoryAllocator.h:53
> +    // Only some of carefully-designed allocator has this.

“Only some carefully-designed allocators have this.”

That said, not sure this comment adds much. It’s better to explain why

> Source/JavaScriptCore/heap/LargeAllocation.cpp:70
> +    size_t allocationSizeAndAlignmentAdjustment = headerSize() + size +
halfAlignment;

Nit: i think a better name is “alignmentAdjustedAllocationSize”

> Source/JavaScriptCore/heap/LargeAllocation.cpp:76
> +    bool oldAlignmentAdjusted = m_alignmentAdjusted;

Nit: another name suggestion, I think this makes more sense as “adjusted
alignment” instead of “alignment adjusted”, e.g “m_adjustedAlignment”


More information about the webkit-reviews mailing list