[webkit-reviews] review granted: [Bug 196133] [JSC] Shrink sizeof(RegExp) : [Attachment 365752] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 22 13:19:06 PDT 2019

Mark Lam <mark.lam at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 196133: [JSC] Shrink sizeof(RegExp)

Attachment 365752: Patch


--- Comment #3 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 365752
  --> https://bugs.webkit.org/attachment.cgi?id=365752

View in context: https://bugs.webkit.org/attachment.cgi?id=365752&action=review

r=me with fixes.

> Source/JavaScriptCore/runtime/RegExp.cpp:266
> +	   auto& jitCode = createRegExpJITCodeIfNecessary();

Let's rename createRegExpJITCodeIfNecessary() to ensureRegExpJITCode().  See

> Source/JavaScriptCore/runtime/RegExp.cpp:324
> +	   auto& jitCode = createRegExpJITCodeIfNecessary();

Ditto: rename.

> Source/JavaScriptCore/runtime/RegExp.cpp:445
> +	       break;

Should this be a RELEASE_ASSERT_NOT_REACHED()?	The pre-existing code implies
that it is not expecting these cases to be possible.

> Source/JavaScriptCore/runtime/RegExp.h:164
> +    Yarr::YarrCodeBlock& createRegExpJITCodeIfNecessary()

Let's call this ensureRegExpJITCode().	I believe that is the way we typically
name this idiom.

More information about the webkit-reviews mailing list