[webkit-reviews] review granted: [Bug 195963] [ews-build] Improve summary for CheckOutSource step : [Attachment 365229] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 19 15:10:24 PDT 2019

Lucas Forschler <lforschler at apple.com> has granted Aakash Jain
<aakash_jain at apple.com>'s request for review:
Bug 195963: [ews-build] Improve summary for CheckOutSource step

Attachment 365229: Patch


--- Comment #4 from Lucas Forschler <lforschler at apple.com> ---
Comment on attachment 365229
  --> https://bugs.webkit.org/attachment.cgi?id=365229

View in context: https://bugs.webkit.org/attachment.cgi?id=365229&action=review

> Tools/BuildSlaveSupport/ews-build/steps.py:103
> +

I think you should not abbreviate summary as 'summ'.  
it only saves a couple chars, so just use stepsummary or step_summary.	or,
just 'summary'

this could also be written:
if self.results != SUCCESS:
    return {u'step': u'Failed to updated working directory'}
     return {u'step': u'Cleaned and updated working directory' }

which avoids the variable name altogether.

More information about the webkit-reviews mailing list