[webkit-reviews] review granted: [Bug 195758] Delay WebProcess launch until a load is triggered in a Web view : [Attachment 365000] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 18 10:23:59 PDT 2019


Geoffrey Garen <ggaren at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 195758: Delay WebProcess launch until a load is triggered in a Web view
https://bugs.webkit.org/show_bug.cgi?id=195758

Attachment 365000: Patch

https://bugs.webkit.org/attachment.cgi?id=365000&action=review




--- Comment #33 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 365000
  --> https://bugs.webkit.org/attachment.cgi?id=365000
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=365000&action=review

r=me

> Source/WebKit/UIProcess/WebPageProxy.cpp:3560
> +    if (!hasRunningProcess() && &process() ==
process().processPool().initialProcessForPages())

Maybe turn !hasRunningProces() into an ASSERT.

> Source/WebKit/UIProcess/WebProcessPool.h:167
> +    WebProcessProxy* initialProcessForPages() const { return
m_initialProcessForPages; }

I think I would call this dummyProcessProxy(), or something similar. "Initial"
is how its clients use it, but not really how it behaves or what it is.

Maybe also add a comment just to explain that this is a convenience object to
avoid null checks, and it doesn't intend to carry any semantic meaning.


More information about the webkit-reviews mailing list