[webkit-reviews] review canceled: [Bug 195000] Add support for incremental bytecode cache updates : [Attachment 363995] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 15 12:07:20 PDT 2019

Tadeu Zagallo <tzagallo at apple.com> has canceled Tadeu Zagallo
<tzagallo at apple.com>'s request for review:
Bug 195000: Add support for incremental bytecode cache updates

Attachment 363995: Patch


--- Comment #13 from Tadeu Zagallo <tzagallo at apple.com> ---
Comment on attachment 363995
  --> https://bugs.webkit.org/attachment.cgi?id=363995

View in context: https://bugs.webkit.org/attachment.cgi?id=363995&action=review

>> Source/JavaScriptCore/jsc.cpp:1003
>> +		m_cachedBytecode.clear();
> do we ever set up a new m_cachedBytecode?

Yes, in `loadBytecode`.

>> Source/JavaScriptCore/runtime/CachedBytecode.cpp:121
>> +	// global code block
> can we just each of these functions better names?
> like addGlobalUpdate and addFunctionUpdate?

Sure, I will do that.

>> Source/JavaScriptCore/runtime/CachedBytecode.cpp:147
>> +	off_t offset = m_payload.size();
> Do we ever update m_payload?

No, `m_payload` is only set in the constructor.

More information about the webkit-reviews mailing list