[webkit-reviews] review granted: [Bug 195747] [PSON] Make sure the WebProcessCache is leverage when relaunching a process after termination : [Attachment 364662] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 14 10:55:13 PDT 2019


Geoffrey Garen <ggaren at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 195747: [PSON] Make sure the WebProcessCache is leverage when relaunching a
process after termination
https://bugs.webkit.org/show_bug.cgi?id=195747

Attachment 364662: Patch

https://bugs.webkit.org/attachment.cgi?id=364662&action=review




--- Comment #2 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 364662
  --> https://bugs.webkit.org/attachment.cgi?id=364662
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=364662&action=review

r=me

> Source/WebKit/UIProcess/WebPageProxy.cpp:737
> +void WebPageProxy::reattachToWebProcess(const RegistrableDomain&
registrableDomain)

At some point we should probably rename this family of functions to downplay
the idea that there used to be a web process. Maybe this should be
"attachToWebProcess" or "launchWebProcess".

> Source/WebKit/UIProcess/WebProcessPool.cpp:1145
> +WebProcessProxy&
WebProcessPool::getNewWebProcessForNavigation(WebsiteDataStore&
websiteDataStore, WebPageProxy* page, const RegistrableDomain&
registrableDomain)

I would call this "webProcessForNavigation".

We usually use the "get" prefix for out parameters.

Also, we might return an old web process that's in cache.


More information about the webkit-reviews mailing list