[webkit-reviews] review granted: [Bug 195510] [ContentChangeObserver] Start observing for content change between touchEnd and mouseMoved start : [Attachment 364113] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Mar 9 11:35:47 PST 2019


Simon Fraser (smfr) <simon.fraser at apple.com> has granted zalan
<zalan at apple.com>'s request for review:
Bug 195510: [ContentChangeObserver] Start observing for content change between
touchEnd and mouseMoved start
https://bugs.webkit.org/show_bug.cgi?id=195510

Attachment 364113: Patch

https://bugs.webkit.org/attachment.cgi?id=364113&action=review




--- Comment #5 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 364113
  --> https://bugs.webkit.org/attachment.cgi?id=364113
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=364113&action=review

> Source/WebCore/page/ios/ContentChangeObserver.h:140
> +    bool isInBetweenTouchEndAndMouseMoved() const { return
m_isInBetweenTouchEndAndMouseMoved; }

Maybe just "isBetweenTouchEndAndMouseMoved" everywhere?

> Source/WebCore/page/ios/ContentChangeObserver.h:198
> +	   || isInBetweenTouchEndAndMouseMoved()

Why use the getter here but not for the others?

> Source/WebKit/WebProcess/WebPage/ios/WebPageIOS.mm:868
> +	  
m_potentialTapNode->document().contentChangeObserver().didCancelTouchEvent();

We're in cancelPotentialTapInFrame() but you're calling didCancelTouchEvent(),
suggesting that didCancelTouchEvent has the wrong name. Aren't we really
canceling the pending synthetic "click"?


More information about the webkit-reviews mailing list