[webkit-reviews] review granted: [Bug 184645] Adjust XMLHttpRequest Content-Type handling : [Attachment 363318] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 1 08:23:22 PST 2019


youenn fablet <youennf at gmail.com> has granted Rob Buis <rbuis at igalia.com>'s
request for review:
Bug 184645: Adjust XMLHttpRequest Content-Type handling
https://bugs.webkit.org/show_bug.cgi?id=184645

Attachment 363318: Patch

https://bugs.webkit.org/attachment.cgi?id=363318&action=review




--- Comment #13 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 363318
  --> https://bugs.webkit.org/attachment.cgi?id=363318
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=363318&action=review

> Source/WebCore/xml/XMLHttpRequest.cpp:77
> +static String replaceCharsetInMediaType(const String& mediaType)

I would rename it to replaceCharsetInMediaTypeIfNeeded.
Thinking about it, chances are that mediaType will be returned without any
change.
We could take a String&& and return a String. Or go back to void/String&.

> Source/WebCore/xml/XMLHttpRequest.cpp:84
> +    return parsedContentType->serialize();

"text/plain; charset=UTF-8" should remain as is and not become
"text/plain;charset=UTF-8", right?
Can we add a test if we do not cover this case?

> LayoutTests/imported/w3c/ChangeLog:8
> +	   Sync test and uodate test expectation (all PASSes).

s/uodate/update/


More information about the webkit-reviews mailing list