[webkit-reviews] review granted: [Bug 198763] [Text autosizing] [iPadOS] Revise our heuristics to determine idempotent text autosizing candidates : [Attachment 372811] Less code, more words

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 24 17:33:01 PDT 2019


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Wenson Hsieh
<wenson_hsieh at apple.com>'s request for review:
Bug 198763: [Text autosizing] [iPadOS] Revise our heuristics to determine
idempotent text autosizing candidates
https://bugs.webkit.org/show_bug.cgi?id=198763

Attachment 372811: Less code, more words

https://bugs.webkit.org/attachment.cgi?id=372811&action=review




--- Comment #10 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 372811
  --> https://bugs.webkit.org/attachment.cgi?id=372811
Less code, more words

View in context: https://bugs.webkit.org/attachment.cgi?id=372811&action=review

> Source/WebCore/ChangeLog:17
> +	   Test:
fast/text-autosizing/ios/idempotentmode/idempotent-autosizing-skip.html

Be careful with "skip" in a test name (I think we have a convention that
filenames with "skipped" in them are skipped). I would call this something
else.

> Source/WebCore/rendering/style/RenderStyle.cpp:497
> +    auto fields =
OptionSet<AutosizeStatus::Fields>::fromRaw(m_inheritedFlags.autosizeStatus);

Need a comment at the top of this function referencing the radar that can point
someone to the tools used to generate this code.


More information about the webkit-reviews mailing list