[webkit-reviews] review granted: [Bug 200272] Web Inspector: Debugger: support emulateUserGesture parameter in Debugger.evaluateOnCallFrame : [Attachment 375167] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 31 15:57:25 PDT 2019


Joseph Pecoraro <joepeck at webkit.org> has granted Devin Rousso
<drousso at apple.com>'s request for review:
Bug 200272: Web Inspector: Debugger: support emulateUserGesture parameter in
Debugger.evaluateOnCallFrame
https://bugs.webkit.org/show_bug.cgi?id=200272

Attachment 375167: Patch

https://bugs.webkit.org/attachment.cgi?id=375167&action=review




--- Comment #3 from Joseph Pecoraro <joepeck at webkit.org> ---
Comment on attachment 375167
  --> https://bugs.webkit.org/attachment.cgi?id=375167
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=375167&action=review

r=me

> Source/JavaScriptCore/inspector/protocol/Debugger.json:283
> -		   { "name": "saveResult", "type": "boolean", "optional": true,
"description": "Whether the resulting value should be considered for saving in
the $n history." }
> +		   { "name": "saveResult", "type": "boolean", "optional": true,
"description": "Whether the resulting value should be considered for saving in
the $n history." },
> +		   { "name": "emulateUserGesture", "type": "boolean",
"optional": true, "description": "Whether the expression should be considered
to be in a user gesture or not." }

We should probably also make this change to:
Source/WebInspectorUI/Versions/Inspector-iOS-13.0.json

> Source/WebInspectorUI/UserInterface/Controllers/RuntimeManager.js:136
> +	       // COMPATIBILITY (iOS 13): "emulateUserGesture" did not exist.

I thought we normally say "Before iOS 13 ... did not exist".

> LayoutTests/ChangeLog:11
> +	   * inspector/debugger/evaluateOnCallFrame-emulateUserGesture.html:
Added.
> +	   *
inspector/debugger/evaluateOnCallFrame-emulateUserGesture-expected.txt: Added.
> +	   *
inspector/debugger/evaluateOnCallFrame-emulateUserGesture-userIsInteracting.htm
l: Added.
> +	   *
inspector/debugger/evaluateOnCallFrame-emulateUserGesture-userIsInteracting-exp
ected.txt: Added.

The other tests are named "userGestureEmulation".  I like this name though.
Maybe we should rename the others.

>
LayoutTests/inspector/debugger/evaluateOnCallFrame-emulateUserGesture-userIsInt
eracting.html:75
> +    <p>Tests for Debugger.evaluateOnCallFrame emulateUserGesture option.</p>

Style: We normally drop this leading whitespace.

> LayoutTests/inspector/debugger/evaluateOnCallFrame-emulateUserGesture.html:75
> +    <p>Tests for Debugger.evaluateOnCallFrame emulateUserGesture option.</p>

Ditto.


More information about the webkit-reviews mailing list