[webkit-reviews] review granted: [Bug 199891] [X86] Emit BT instruction for shift + mask in B3 : [Attachment 375001] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 26 17:58:57 PDT 2019


Keith Miller <keith_miller at apple.com> has granted Justin Michaud
<justin_michaud at apple.com>'s request for review:
Bug 199891: [X86] Emit BT instruction for shift + mask in B3
https://bugs.webkit.org/show_bug.cgi?id=199891

Attachment 375001: Patch

https://bugs.webkit.org/attachment.cgi?id=375001&action=review




--- Comment #15 from Keith Miller <keith_miller at apple.com> ---
Comment on attachment 375001
  --> https://bugs.webkit.org/attachment.cgi?id=375001
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=375001&action=review

r=me.

> Source/JavaScriptCore/b3/B3LowerToAir.cpp:3335
> +		       Value* bitBase = nullptr;

Can we call this value or testValue? bitBase is kinda confusing.

It would probably be good to change this everywhere.

> Source/JavaScriptCore/b3/B3LowerToAir.cpp:3375
> +			   for (auto& basePromise :
Vector<ArgPromise>::from(loadPromise(bitBase), tmpPromise(bitBase))) {

I think you can just do:

for (auto& basePromise : { loadPromise(bitBase), tmpPromise(bitBase) }) {

You also won't do a heap allocation that way. Although, maybe the compiler will
elide that?


More information about the webkit-reviews mailing list