[webkit-reviews] review granted: [Bug 194084] [JSC] Do not use InferredValue in non-JIT configuration : [Attachment 360711] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Jan 31 08:37:49 PST 2019
Saam Barati <sbarati at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 194084: [JSC] Do not use InferredValue in non-JIT configuration
https://bugs.webkit.org/show_bug.cgi?id=194084
Attachment 360711: Patch
https://bugs.webkit.org/attachment.cgi?id=360711&action=review
--- Comment #14 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 360711
--> https://bugs.webkit.org/attachment.cgi?id=360711
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=360711&action=review
> Source/JavaScriptCore/ChangeLog:10
> + is preferable target for poly proto. But in this case, we do not
need to have full InferredValue. Just holding WatchpointState
It’s worth actually explaining what you’re doing here. You’re seeing if we ever
create more than once. And you’re also saying only the JIT cares about the
actual function being inferred
> Source/JavaScriptCore/runtime/FunctionExecutable.h:193
> + void notifyWrite(VM& vm, JSValue value, const char* reason)
This name makes less sense in this context. You should rename it to make more
sense. Maybe notifyCreation.
More information about the webkit-reviews
mailing list