[webkit-reviews] review granted: [Bug 192826] [WHLSL] Add a Visitor class : [Attachment 358911] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 11 16:34:36 PST 2019


Dean Jackson <dino at apple.com> has granted Myles C. Maxfield
<mmaxfield at apple.com>'s request for review:
Bug 192826: [WHLSL] Add a Visitor class
https://bugs.webkit.org/show_bug.cgi?id=192826

Attachment 358911: Patch

https://bugs.webkit.org/attachment.cgi?id=358911&action=review




--- Comment #7 from Dean Jackson <dino at apple.com> ---
Comment on attachment 358911
  --> https://bugs.webkit.org/attachment.cgi?id=358911
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=358911&action=review

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLVisitor.cpp:2
> + * Copyright (C) 2018 Apple Inc. All rights reserved.

2019

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLVisitor.cpp:105
> +    // These visiting functions might add new global statements, so don't
use foreach syntax.

:(

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLVisitor.cpp:357
> +    WTF::visit(WTF::makeVisitor([&](AST::NumThreadsFunctionAttribute&
numThreadsFunctionAttribute) {
> +	   checkErrorAndVisit(numThreadsFunctionAttribute);
> +    }), functionAttribute);

Why not call it directly since there is only one object to visit?

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLVisitor.h:2
> + * Copyright (C) 2018 Apple Inc. All rights reserved.

2019

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLVisitor.h:179
> +    void checkErrorAndVisit(Program&);

Could these be private/protected?


More information about the webkit-reviews mailing list