[webkit-reviews] review granted: [Bug 193246] ASSERT when paused in debugger and console evaluation causes exception : [Attachment 358634] [PATCH] Proposed Fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 8 14:05:43 PST 2019


Mark Lam <mark.lam at apple.com> has granted Joseph Pecoraro
<joepeck at webkit.org>'s request for review:
Bug 193246: ASSERT when paused in debugger and console evaluation causes
exception
https://bugs.webkit.org/show_bug.cgi?id=193246

Attachment 358634: [PATCH] Proposed Fix

https://bugs.webkit.org/attachment.cgi?id=358634&action=review




--- Comment #4 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 358634
  --> https://bugs.webkit.org/attachment.cgi?id=358634
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=358634&action=review

r=me with some suggestions.

> Source/JavaScriptCore/debugger/DebuggerEvalEnabler.h:37
> +	   EvalOnCurrentFrame,
> +	   EvalOnDebuggerCallFrame,

Now that I have more time to think about it, how about naming these as:
    EvalOnCurrentFrame => EvalOnCurrentCallFrame
    EvalOnDebuggerCallFrame => EvalOnCallFrameAtDebuggerEntry

I think these names would be clearer.  What do you think?

> Source/JavaScriptCore/runtime/JSGlobalObject.h:494
> +    const ExecState* m_evalDebuggerCallFrame { nullptr };

I suggest naming this as "m_callFrameAtDebuggerEntry" instead.

> Source/JavaScriptCore/runtime/JSGlobalObject.h:904
> +    const ExecState* evalDebuggerCallFrame() const { return
m_evalDebuggerCallFrame; }
> +    void setEvalDebuggerCallFrame(const ExecState* callFrame) {
m_evalDebuggerCallFrame = callFrame; }

I suggest renaming these as callFrameAtDebuggerEntry() and
setCallFrameAtDebuggerEntry() instead.


More information about the webkit-reviews mailing list