[webkit-reviews] review granted: [Bug 194892] scalableNativeWebpageParameters() is not preserved on new page navigation. : [Attachment 362768] Fix a failed layout test again.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 25 14:53:18 PST 2019


Wenson Hsieh <wenson_hsieh at apple.com> has granted Yongjun Zhang
<yongjun_zhang at apple.com>'s request for review:
Bug 194892: scalableNativeWebpageParameters() is not preserved on new page
navigation.
https://bugs.webkit.org/show_bug.cgi?id=194892

Attachment 362768: Fix a failed layout test again.

https://bugs.webkit.org/attachment.cgi?id=362768&action=review




--- Comment #13 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 362768
  --> https://bugs.webkit.org/attachment.cgi?id=362768
Fix a failed layout test again.

View in context: https://bugs.webkit.org/attachment.cgi?id=362768&action=review

> Source/WebCore/page/ViewportConfiguration.cpp:336
> +ViewportConfiguration::Parameters
ViewportConfiguration::fixedNativeWebpageParameters()

It's somewhat confusing that nativeWebpageParameters splits off into
scalableNativeWebpageParameters or fixedNativeWebpageParameters. I think
fixedNativeWebpageParameters is a bit of a strange name too (the key point here
is that the fixed parameters don't allow shrink to fit, right?)

Maybe we can make this more explicit, like...

nativeWebpageParameters() returns either
nativeWebpageParametersWithShrinkToFit() or
nativeWebpageParametersWithoutShrinkToFit()?

> Tools/WebKitTestRunner/UIScriptControllerCocoa.mm:60
> +   
TestController::singleton().mainWebView()->platformView()._allowsViewportShrink
ToFit = allows;

Nit - I think you could just put this in UIScriptControllerIOS.mm, since
_allowsViewportShrinkToFit is only available on iOS.


More information about the webkit-reviews mailing list