[webkit-reviews] review granted: [Bug 194694] [bmalloc] NSBundle-based application name check should be executed after debug-heap environment variable check : [Attachment 362103] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 15 01:03:29 PST 2019


Mark Lam <mark.lam at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 194694: [bmalloc] NSBundle-based application name check should be executed
after debug-heap environment variable check
https://bugs.webkit.org/show_bug.cgi?id=194694

Attachment 362103: Patch

https://bugs.webkit.org/attachment.cgi?id=362103&action=review




--- Comment #2 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 362103
  --> https://bugs.webkit.org/attachment.cgi?id=362103
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=362103&action=review

r=me with suggested improvement.

> Source/bmalloc/bmalloc/Gigacage.cpp:271
>	       bool result =
!PerProcess<Environment>::get()->isDebugHeapEnabled();
>	       if (!result)

This is not related to your patch but since you're in this code, let's fix this
too:
1. the name "result" is not meaningful.  Let's call it debugHeapEnabled
instead.
2. the double negative is hard to follow.  Let's not negate the result of
PerProcess<Environment>::get()->isDebugHeapEnabled(), and let's not negate the
boolean value in the if check.


More information about the webkit-reviews mailing list