[webkit-reviews] review granted: [Bug 194551] [WPE][GTK] Merge WebProcessPoolWPE.cpp and WebProcessPoolGtk.cpp : [Attachment 361820] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 12 23:30:11 PST 2019

Carlos Garcia Campos <cgarcia at igalia.com> has granted Michael Catanzaro
<mcatanzaro at igalia.com>'s request for review:
Bug 194551: [WPE][GTK] Merge WebProcessPoolWPE.cpp and WebProcessPoolGtk.cpp

Attachment 361820: Patch


--- Comment #2 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 361820
  --> https://bugs.webkit.org/attachment.cgi?id=361820

View in context: https://bugs.webkit.org/attachment.cgi?id=361820&action=review

> Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp:43
> +#include "APIProcessPoolConfiguration.h"
> +#include "Logging.h"
> +#include "WebCookieManagerProxy.h"
> +#include "WebMemoryPressureHandler.h"
> +#include "WebProcessCreationParameters.h"
> +#include "WebProcessMessages.h"
> +#include <JavaScriptCore/RemoteInspectorServer.h>
> +#include <WebCore/GStreamerCommon.h>
> +#include <WebCore/NotImplemented.h>
> +#include <WebCore/SchemeRegistry.h>
> +#include <wtf/FileSystem.h>
> +#include <wtf/glib/GUniquePtr.h>
> +#include <wtf/text/CString.h>

This is a good opportunity to clean up the include headers, I'm sure we can
remove some of them.

> Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp:101
> +    // This is misnamed. It can only be used to disable complex text.
> +    parameters.shouldAlwaysUseComplexTextCodePath = true;
> +    const char* forceComplexText = getenv("WEBKIT_FORCE_COMPLEX_TEXT");
> +    if (forceComplexText && !strcmp(forceComplexText, "0"))

It's only for debugging, so we can just rename it. There isn't any script
currently using it (WKTR used it to disable complex text in layout tests). I
think we can use it in wpe too (in that case to force complex text).

More information about the webkit-reviews mailing list