[webkit-reviews] review granted: [Bug 194201] [GTK] Allow pinch zoom on touchpad : [Attachment 361011] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Feb 3 12:32:47 PST 2019
Michael Catanzaro <mcatanzaro at igalia.com> has granted Alexander Mikhaylenko
<exalm7659 at gmail.com>'s request for review:
Bug 194201: [GTK] Allow pinch zoom on touchpad
https://bugs.webkit.org/show_bug.cgi?id=194201
Attachment 361011: Patch
https://bugs.webkit.org/attachment.cgi?id=361011&action=review
--- Comment #3 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 361011
--> https://bugs.webkit.org/attachment.cgi?id=361011
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=361011&action=review
Does this depend on the other patch? If not, you can request cq? for
commit-queue.
> Source/WebKit/UIProcess/API/gtk/WebKitWebViewBase.cpp:1202
> + if (event->type == GDK_TOUCHPAD_PINCH) {
> + WebKitWebViewBase* webViewBase = WEBKIT_WEB_VIEW_BASE(widget);
> + GestureController& controller =
webkitWebViewBaseGestureController(webViewBase);
> + controller.handleEvent(event);
> + }
Style: just do it on one line:
if (event->type == GDK_TOUCHPAD_PINCH)
webkitWebViewBaseGestureController(WEBKIT_WEB_VIEW_BASE(widget)).handleEvent(ev
ent);
In C it would be too hard to read if we don't use multiple lines, but this is
C++. :)
More information about the webkit-reviews
mailing list