[webkit-reviews] review granted: [Bug 194189] Validate navigation policy decisions to avoid crashes in continueLoadAfterNavigationPolicy : [Attachment 360970] Updated for trunk

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 2 12:52:32 PST 2019


Geoffrey Garen <ggaren at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 194189: Validate navigation policy decisions to avoid crashes in
continueLoadAfterNavigationPolicy
https://bugs.webkit.org/show_bug.cgi?id=194189

Attachment 360970: Updated for trunk

https://bugs.webkit.org/attachment.cgi?id=360970&action=review




--- Comment #5 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 360970
  --> https://bugs.webkit.org/attachment.cgi?id=360970
Updated for trunk

View in context: https://bugs.webkit.org/attachment.cgi?id=360970&action=review

r=me, please fix the Windows build

> Source/WebCore/loader/FrameLoaderTypes.h:72
> +    PolicyCheckIdentifier() = default;

Is it valid to construct a null PolicyCheckIdentifier? Is it necessary? Maybe
we should = delete this.

> Source/WebCore/loader/FrameLoaderTypes.h:75
> +    static PolicyCheckIdentifier generate();

I think we usually call this function "create".

> Source/WebCore/loader/FrameLoaderTypes.h:89
> +    uint64_t m_check { 0 };

I would call this m_policyCheck.

> Source/WebCore/loader/PolicyChecker.cpp:84
> +    RELEASE_ASSERT_WITH_MESSAGE(m_check, "Received a non-generated policy
check identifier");

Maybe call this a null policy check identifier? Not clear what "non-generated"
means, and in theory some non-generated values might be non-zero.


More information about the webkit-reviews mailing list